U ��.e�7�@sldZddlmZddlZddlZdZefZz eefZWne k rJYnXze Z Wn$e k rxe Z e e kstt�YnXddkr�dd�Zndd�Zz ejZWnek r�dd �ZYnXd d �Zeed �r�d d�Zndd�ZdNdd�ZGdd�de�ZdZdZGdd�de�ZGdd�de�Zdd�ZdOdd�Zd d!�Z d"d#�Z!d$d%�Z"d&d'�Z#d(d)�Z$d*d+�Z%d,d-�Z&d.d/�Z'd0d1�Z(d2d3�Z)Gd4d5�d5e�Z*Gd6d7�d7e*�Z+Gd8d9�d9e*�Z,Gd:d;�d;e�Z-Gdd?�d?e.�Z/Gd@dA�dAe-e,�Z0GdBdC�dCe�Z1e1e._2GdDdE�dEe�Z3GdFdG�dGe3e+�Z4GdHdI�dIe4�Z5GdJdK�dKe3e,�Z6GdLdM�dMe�Z7e7e4_2dS)Pz�A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. �)�unicode_literalsNz1.0.22cCs|S�N��Zbytrr�9/usr/lib/python3.8/site-packages/pip/_vendor/ipaddress.py�_compat_bytes_to_byte_valssrcCsdd�|D�S)NcSsg|]}t�d|�d�qS)�!Br)�struct�unpack��.0�brrr� #sz._compat_bytes_to_byte_vals..rrrrrr"scCs8|dks t�d}|D]}t|t�s&t�|d>|}q|S)N�bigr�)�AssertionError� isinstance�_compat_int_types)Zbytvals� endianess�resZbvrrr�_compat_int_from_byte_vals's  rcCs�t|t�st�|dkst�|dkrH|dks2|dkr7}|d|j kr�q�q�dS) a�Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networks�%%s and %s are not of the same versionz*last IP address must be greater than firstr�zunknown IP versionr&N) r� _BaseAddress� TypeError�versionrGrKrL�_max_prefixlenr^rergr"� _ALL_ONES)rarbrcZip_bitsZ first_intZlast_intZnbits�netrrr�summarize_address_rangeBs8 � �   � rpccs�t|�}i}|rV|��}|��}|�|�}|dkr<|||<q ||kr ||=|�|�q d}t|���D]$}|dk r�|j|jkr�qf|V|}qfdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)�list�pop�supernet�get�append�sorted�values�broadcast_address)r_Zto_merge�subnetsrorsZexistingrbrrr�_collapse_addresses_internalys$    rzc Cs0g}g}g}|D]�}t|t�rR|rF|dj|jkrFtd||df��|�|�q|j|jkr�|r�|dj|jkr�td||df��z|�|j�Wq�tk r�|�|j �Yq�Xq|r�|dj|jkr�td||df��|�|�qt t |��}|�r$t |�D]\}}|� t||���qt||�S)a�Collapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterator of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. �����rh)rrj�_versionrkru� _prefixlenrmrc�AttributeError�network_addressrv�setrd�extendrprz)r_ZaddrsZipsZnetsrcrarbrrr�collapse_addresses�s@ �  ��  r�cCs(t|t�r|��St|t�r$|��StS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r� _BaseNetwork�_get_networks_keyrj�_get_address_keyr1)�objrrr�get_mixed_type_key�s   r�c@s�eZdZdZdZedd��Zedd��Zedd��Zed d ��Z d d �Z d d�Z e dd��Z e dd��Ze dd��Ze dd��Ze dd��Zdd�ZdS)�_IPAddressBasezThe mother class.rcCs|��S)z:Return the longhand version of the IP address as a string.)�_explode_shorthand_ip_string�r.rrr�exploded�sz_IPAddressBase.explodedcCst|�S)z;Return the shorthand version of the IP address as a string.�rWr�rrr� compressedsz_IPAddressBase.compressedcCs|��S)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )�_reverse_pointerr�rrr�reverse_pointer s z_IPAddressBase.reverse_pointercCsdt|�f}t|��dS)Nz%200s has no version specified��typer�r.�msgrrrrlsz_IPAddressBase.versioncCsF|dkrd}t|||jf��||jkrBd}t|||j|jf��dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)r@r|rnrm)r.rIr�rrr�_check_int_addresss  �z!_IPAddressBase._check_int_addresscCs.t|�}||kr*d}t|||||jf��dS)Nz~%r (len %d != %d) is not permitted as an IPv%d address. Did you pass in a bytes (str in Python 2) instead of a unicode object?)rYr@r|)r.rIZ expected_lenZ address_lenr�rrr�_check_packed_address"s��z$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z�Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rn)�cls� prefixlenrrr�_ip_int_from_prefix,s z"_IPAddressBase._ip_int_from_prefixc Cs\t||j�}|j|}||?}d|>d}||krX|jd}t||d�}d}t||��|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r&rrz&Netmask pattern %r mixes zeroes & ones)rgrmrrG) r��ip_intZtrailing_zeroesr�Z leading_onesZall_onesZbyteslenZdetailsr�rrr�_prefix_from_ip_int9s �     z"_IPAddressBase._prefix_from_ip_intcCsd|}t|��dS)Nz%r is not a valid netmask)rC)r�Z netmask_strr�rrr�_report_invalid_netmaskRsz&_IPAddressBase._report_invalid_netmaskcCshtj�|�s|�|�z t|�}Wntk r@|�|�YnXd|krX|jksdn|�|�|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)�_BaseV4�_DECIMAL_DIGITS� issupersetr��intrGrm)r�Z prefixlen_strr�rrr�_prefix_from_prefix_stringWs    z)_IPAddressBase._prefix_from_prefix_stringcCs�z|�|�}Wntk r,|�|�YnXz |�|�WStk rNYnX||jN}z |�|�WStk r�|�|�YnXdS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)�_ip_int_from_stringr@r�r�rGrn)r��ip_strr�rrr�_prefix_from_ip_stringps   z%_IPAddressBase._prefix_from_ip_stringcCs|jt|�ffSr)� __class__rWr�rrr� __reduce__�sz_IPAddressBase.__reduce__N)r;r<r=rBr>�propertyr�r�r�rlr�r�� classmethodr�r�r�r�r�r�rrrrr��s.           !r�c@sdeZdZdZdZdd�Zdd�Zdd�Zd d �Zd d �Z d d�Z dd�Z dd�Z dd�Z dd�ZdS)rjz�A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. rcCs|jSr�r^r�rrr�__int__�sz_BaseAddress.__int__cCs8z|j|jko|j|jkWStk r2tYSXdSr)r^r|r~r1r-rrrr0�s   �z_BaseAddress.__eq__cCs`t|t�stSt|t�s(td||f��|j|jkrDtd||f��|j|jkr\|j|jkSdS�N�"%s and %s are not of the same typerhF)rr�r1rjrkr|r^r-rrrr4�s  � �  z_BaseAddress.__lt__cCs t|t�stS|�t|�|�Sr�rrr1r�r�r-rrr�__add__�s z_BaseAddress.__add__cCs t|t�stS|�t|�|�Srr�r-rrr�__sub__�s z_BaseAddress.__sub__cCsd|jjt|�fS�Nz%s(%r)�r�r;rWr�rrr�__repr__�sz_BaseAddress.__repr__cCst|�|j��Sr)rW�_string_from_ip_intr^r�rrr�__str__�sz_BaseAddress.__str__cCsttt|j���Sr)�hash�hexr�r^r�rrr�__hash__�sz_BaseAddress.__hash__cCs |j|fSr�r|r�rrrr��sz_BaseAddress._get_address_keycCs|j|jffSr)r�r^r�rrrr��sz_BaseAddress.__reduce__N)r;r<r=rBr>r�r0r4r�r�r�r�r�r�r�rrrrrj�srjc@sdeZdZdZdd�Zdd�Zdd�Zdd �Zd d �Zd d �Z dd�Z dd�Z dd�Z dd�Z dd�Zedd��Zedd��Zedd��Zedd��Zed d!��Zed"d#��Zed$d%��Zed&d'��Zd(d)�Zd*d+�Zd,d-�ZdHd0d1�ZdId2d3�Zed4d5��Zed6d7��Zd8d9�Z d:d;�Z!edd?��Z#ed@dA��Z$edBdC��Z%edDdE��Z&edFdG��Z'd/S)Jr�z~A generic IP network object. This IP class contains the version independent methods which are used by networks. cCs i|_dSr)�_cache)r.rIrrr�__init__�sz_BaseNetwork.__init__cCsd|jjt|�fSr�r�r�rrrr��sz_BaseNetwork.__repr__cCsd|j|jfS�N�%s/%d)rr�r�rrrr��sz_BaseNetwork.__str__ccs8t|j�}t|j�}t|d|�D]}|�|�Vq"dS)z�Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r&N�r�rrxr*�_address_class�r.�network� broadcast�xrrr�hosts�s  z_BaseNetwork.hostsccs8t|j�}t|j�}t||d�D]}|�|�Vq"dS�Nr&r�r�rrr�__iter__�s  z_BaseNetwork.__iter__cCslt|j�}t|j�}|dkr>|||kr0td��|�||�S|d7}|||krZtd��|�||�SdS)Nrzaddress out of ranger&)r�rrx� IndexErrorr�)r.�nr�r�rrr� __getitem__�s    z_BaseNetwork.__getitem__cCsxt|t�stSt|t�s(td||f��|j|jkrDtd||f��|j|jkr\|j|jkS|j|jkrt|j|jkSdSr�)rr�r1r�rkr|r�netmaskr-rrrr4s"  � �    z_BaseNetwork.__lt__cCsLz.|j|jko,|j|jko,t|j�t|j�kWStk rFtYSXdSr)r|rr�r�r~r1r-rrrr0s  ��z_BaseNetwork.__eq__cCstt|j�t|j�A�Sr)r�r�rr�r�rrrr�sz_BaseNetwork.__hash__cCsL|j|jkrdSt|t�rdSt|j�t|j�koBt|j�kSSdS�NF)r|rr�r�rr^rxr-rrr� __contains__s  �z_BaseNetwork.__contains__cCs(|j|kp&|j|kp&|j|kp&|j|kS)z*Tell if self is partly contained in other.)rrxr-rrr�overlaps*s    �z_BaseNetwork.overlapscCs<|j�d�}|dkr8|�t|j�t|j�B�}||jd<|S)Nrx)r�rtr�r�r�hostmask�r.r�rrrrx1s  � z_BaseNetwork.broadcast_addresscCs8|j�d�}|dkr4|�t|j�|jA�}||jd<|S)Nr�)r�rtr�r�r�rnr�rrrr�:s   z_BaseNetwork.hostmaskcCsd|j|jfSr�)rr}r�rrr�with_prefixlenBsz_BaseNetwork.with_prefixlencCsd|j|jfS�N�%s/%s)rr�r�rrr� with_netmaskFsz_BaseNetwork.with_netmaskcCsd|j|jfSr�)rr�r�rrr� with_hostmaskJsz_BaseNetwork.with_hostmaskcCst|j�t|j�dS)z&Number of hosts in the current subnet.r&)r�rxrr�rrr� num_addressesNsz_BaseNetwork.num_addressescCsdt|�f}t|��dS)Nz%%200s has no associated address classr�r�rrrr�Ssz_BaseNetwork._address_classcCs|jSr)r}r�rrrr�[sz_BaseNetwork.prefixlenccs|j|jkstd||f��t|t�s2td|��|�|�sLtd||f��||krXdS|�d|j|jf�}|� �\}}||kr�||kr�|�|�r�|V|� �\}}qz|�|�r�|V|� �\}}qzt d|||f��qz||kr�|Vn"||kr�|Vnt d|||f��dS)a�Remove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. rhz%s is not a network objectz%s not contained in %sNr�z3Error performing exclusion: s1: %s s2: %s other: %s) r|rkrr�� subnet_ofrGr�rr�ryr)r.r/�s1�s2rrr�address_exclude_s@$ �    �   ��z_BaseNetwork.address_excludecCs`|j|jkrtd||f��|j|jkr,dS|j|jkr other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. r�r{r&r)r|rkrr�r-rrr�compare_networks�s! �    z_BaseNetwork.compare_networkscCs|j|j|jfS)z�Network-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )r|rr�r�rrrr��sz_BaseNetwork._get_networks_keyr&Nc cs�|j|jkr|VdS|dk rJ||jkr0td��|dkr@td��||j}|dkrZtd��|j|}||jkr~td||f��t|j�}t|j�d}t|j�d|?}t|||�D]}|�||f�}|Vq�dS)a�The subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr&�(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) r}rmrGr�rrxr�r*r�) r.�prefixlen_diff� new_prefix� new_prefixlenr'r(r)Znew_addrZcurrentrrrry�s2     �� z_BaseNetwork.subnetscCs�|jdkr|S|dk rB||jkr(td��|dkr8td��|j|}|j|}|dkrftd|j|f��|�t|j�t|j�|>@|f�S)a�The supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr&r�z;current prefixlen is %d, cannot have a prefixlen_diff of %d)r}rGr�r�r�rr�)r.r�r�r�rrrrss&    ���z_BaseNetwork.supernetcCs|jjo|jjS�z�Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )r� is_multicastrxr�rrrr�As �z_BaseNetwork.is_multicastcCs^z4|j|jkrtd||���|j|jko2|j|jkWStk rXtd||f��YnXdS)Nrhz3Unable to test subnet containment between %s and %s)r|rkrrxr~)�ar rrr� _is_subnet_ofMs   ��z_BaseNetwork._is_subnet_ofcCs |�||�S)z1Return True if this network is a subnet of other.�r�r-rrrr�Ysz_BaseNetwork.subnet_ofcCs |�||�S)z3Return True if this network is a supernet of other.r�r-rrr� supernet_of]sz_BaseNetwork.supernet_ofcCs|jjo|jjS)��Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )r� is_reservedrxr�rrrr�as �z_BaseNetwork.is_reservedcCs|jjo|jjS�z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )r� is_link_localrxr�rrrr�ms�z_BaseNetwork.is_link_localcCs|jjo|jjS)z�Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )r� is_privaterxr�rrrr�xs �z_BaseNetwork.is_privatecCs|j S)z�Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. �r�r�rrr� is_global�s z_BaseNetwork.is_globalcCs|jjo|jjS)��Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )r�is_unspecifiedrxr�rrrr��s �z_BaseNetwork.is_unspecifiedcCs|jjo|jjS)��Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )r� is_loopbackrxr�rrrr��s �z_BaseNetwork.is_loopback)r&N)r&N)(r;r<r=rBr�r�r�r�r�r�r4r0r�r�r�r�rxr�r�r�r�r�r�r�r�r�r�ryrsr�� staticmethodr�r�r�r�r�r�r�r�r�rrrrr��sf           K0 5 (       r�c @s�eZdZdZdZdZdedZed�Z eddd d d d d ddg �Z eZ iZ dd�Z edd��Zedd��Zedd��Zedd��Zdd�Zdd�Zedd��Zed d!��Zd"S)#r�zyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. rrrr&� 0123456789��������������rrcCst|�Srr�r�rrrr��sz$_BaseV4._explode_shorthand_ip_stringcCsn||jkrdt|t�r|}n.z|�|�}Wntk rF|�|�}YnXt|�|��}||f|j|<|j|S�aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") )�_netmask_cacherrr�rCr�rDr��r��argr�r�rrr� _make_netmask�s  z_BaseV4._make_netmaskc Csz|s td��|�d�}t|�dkr.td|��ztt|j|�d�WStk rt}ztd||f��W5d}~XYnXdS)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. �Address cannot be empty�.rzExpected 4 octets in %rr�%s in %rN)r@rXrYr�map� _parse_octetrG)r�r�Zoctets�excrrrr��s    �z_BaseV4._ip_int_from_stringcCs�|s td��|j�|�s(d}t||��t|�dkrDd}t||��t|d�}|dkrr|ddkrrd }t||��|d kr�td |��|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %r�z$At most 3 characters permitted in %r� �r�0z3Ambiguous (octal/decimal) value in %r not permittedr�zOctet %d (> 255) not permitted)rGr�r�rYr�)r�Z octet_strr�Z octet_intrrrr�s       z_BaseV4._parse_octetcCsd�dd�t|dd�D��S)z�Turns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. r�css0|](}tt|t�r"t�d|�dn|�VqdS)rrN)rWrrFr r r rrr� %s ���z._BaseV4._string_from_ip_int..rr)�joinr)r�r�rrrr�s  �z_BaseV4._string_from_ip_intcsj|�d�}z�fdd�tt|�D�}Wntk r<YdSXt|�t|�krRdS|d|dkrfdSdS)z�Test if the IP string is a hostmask (rather than a netmask). Args: ip_str: A string, the potential hostmask. Returns: A boolean, True if the IP string is a hostmask. r�csg|]}|�jkr|�qSr)�_valid_mask_octets�r r�r�rrr6s z(_BaseV4._is_hostmask..Frr{T)rXr�r�rGrY)r.r�rf�partsrr�r� _is_hostmask*s z_BaseV4._is_hostmaskcCs&t|��d�ddd�}d�|�dS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. r�Nr{z .in-addr.arpa)rWrXr)r.Zreverse_octetsrrrr�?sz_BaseV4._reverse_pointercCs|jSr�rmr�rrr� max_prefixlenHsz_BaseV4.max_prefixlencCs|jSrr�r�rrrrlLsz_BaseV4.versionN)r;r<r=rBr>r|� IPV4LENGTHrn� frozensetr�rrmr�r�r�r�r�rr�r r�r�r rlrrrrr��s.    $   r�c@s|eZdZdZdZdd�Zedd��Zedd��Zed d ��Z ed d ��Z ed d��Z edd��Z edd��Z edd��ZdS)rDz/Represent and manipulate single IPv4 Addresses.�r^� __weakref__cCsxt|t�r|�|�||_dSt|t�rL|�|d�t|�}t|d�|_dSt|�}d|krht d|��|� |�|_dS)a� Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NrrrV�Unexpected '/' in %r� rrr�r^rFr�rrrWr@r��r.rIZbvsZaddr_strrrrr�Ws      zIPv4Address.__init__cCs t|j�S�z*The binary representation of this address.)rTr^r�rrr�packed{szIPv4Address.packedcCs ||jjkS)z�Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )� _constants�_reserved_networkr�rrrr��s zIPv4Address.is_reservedcst�fdd��jjD��S)z�Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry. c3s|]}�|kVqdSrr�r ror�rrr�sz)IPv4Address.is_private..��anyr�_private_networksr�rr�rr��s zIPv4Address.is_privatecCs||jjko|j Sr)r�_public_networkr�r�rrrr��s �zIPv4Address.is_globalcCs ||jjkS)z�Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. �r�_multicast_networkr�rrrr��s zIPv4Address.is_multicastcCs ||jjkS)z�Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )r�_unspecified_addressr�rrrr��s zIPv4Address.is_unspecifiedcCs ||jjkS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )r�_loopback_networkr�rrrr��szIPv4Address.is_loopbackcCs ||jjkS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. �r�_linklocal_networkr�rrrr��szIPv4Address.is_link_localN)r;r<r=rBr>r�r�rr�r�r�r�r�r�r�rrrrrDQs&$       rDc@sjeZdZdd�Zdd�Zdd�Zdd�Zd d �Zej Z e d d ��Z e d d��Z e dd��Z e dd��ZdS)rOcCs�t|ttf�r2t�||�t|j�|_|j|_ dSt|t �r�t�||d�t |�dkrht |d�|_ n|j|_ t|dd�|_|jj |_ |jj|_dSt|�}t�||d�t|dd�|_|jj |_ |jj |_ |jj|_dS�Nrr&F)rM)rrFrrDr�rKr^r�rmr}�tuplerYr�r�r�r[�r.rIrZrrrr��s(        zIPv4Interface.__init__cCsd|�|j�|jjfSr��r�r^r�r�r�rrrr��s �zIPv4Interface.__str__cCsFt�||�}|r|tkr|Sz|j|jkWStk r@YdSXdSr�)rDr0r1r�r~�r.r/Z address_equalrrrr0�s  zIPv4Interface.__eq__cCsRt�||�}|tkrtSz|j|jkp4|j|jko4|WStk rLYdSXdSr�)rDr4r1r�r~�r.r/Z address_lessrrrr4�s  �zIPv4Interface.__lt__cCs|j|jAt|jj�ASr�r^r}r�r�rr�rrrr�szIPv4Interface.__hash__cCs t|j�Sr)rDr^r�rrrrcszIPv4Interface.ipcCsd|�|j�|jfSr��r�r^r}r�rrrr� s �zIPv4Interface.with_prefixlencCsd|�|j�|jfSr��r�r^r�r�rrrr�s �zIPv4Interface.with_netmaskcCsd|�|j�|jfSr��r�r^r�r�rrrr�s �zIPv4Interface.with_hostmaskN)r;r<r=r�r�r0r4r�r�r�r�rcr�r�r�rrrrrO�s     rOc@s*eZdZdZeZddd�Zedd��ZdS) rKaeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 TcCs|t�||�t|ttf�r| d | K} t | d�D] } | d K} | |� || �O} �qx| WSt k �r�}ztd||f��W5d}~XYnXdS)z�Turn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. r��:rz At least %d parts expected in %rr�r{r�N�%xr���r&z!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) r@rXrYrDrrr^ru� _HEXTET_COUNTr*�range� _parse_hextetrG)r�r�r Z _min_partsr�Zipv4_intrZ _max_partsZ skip_indexr!Zparts_hiZparts_loZ parts_skippedr�rrrr��s�    "  �             z_BaseV6._ip_int_from_stringcCs>|j�|�std|��t|�dkr4d}t||��t|d�S)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr)� _HEX_DIGITSr�rGrYr�)r�Z hextet_strr�rrrr8>s     z_BaseV6._parse_hextetc Cs�d}d}d}d}t|�D]>\}}|dkrN|d7}|dkr<|}||krV|}|}qd}d}q|dkr�||}|t|�kr~|dg7}dg|||�<|dkr�dg|}|S)a�Compresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. r{rrr&�)� enumeraterY) r��hextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_len�indexZhextetZbest_doublecolon_endrrr�_compress_hextetsXs0�   z_BaseV6._compress_hextetsNcsZ|dkrt|j�}||jkr$td��d|��fdd�tddd�D�}|�|�}d �|�S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too large�%032xcs&g|]}dt�||d�d��qS)r4rr)r�r �Zhex_strrrr�sz/_BaseV6._string_from_ip_int..rr?rr3)r�r^rnrGr7r>r)r�r�r<rr@rr��s   z_BaseV6._string_from_ip_intcs�t|t�rt|j�}nt|t�r,t|j�}nt|�}|�|�}d|��fdd�tddd�D�}t|ttf�r�dd� |�|j fSd� |�S) z�Expand a shortened IPv6 address. Args: ip_str: A string, the IPv6 address. Returns: A string, the expanded IPv6 address. r?csg|]}�||d��qS)rrr r@rrr�sz8_BaseV6._explode_shorthand_ip_string..rr?rr�r3) rrLrWrrPrcr�r7r�rr})r.r�r�r rr@rr��s     z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd��dd�}d�|�dS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. Nr{r3r:r�z .ip6.arpa)r��replacer)r.Z reverse_charsrrrr��sz_BaseV6._reverse_pointercCs|jSrr r�rrrr �sz_BaseV6.max_prefixlencCs|jSrr�r�rrrrl�sz_BaseV6.version)N)r;r<r=rBr>r|� IPV6LENGTHrnr6rr9rmr�r�r�r�r8r>r�r�r�r�r rlrrrrr2�s0   h  /   r2c@s�eZdZdZdZdd�Zedd��Zedd��Zed d ��Z ed d ��Z ed d��Z edd��Z edd��Z edd��Zedd��Zedd��Zedd��Zedd��ZdS)rEz/Represent and manipulate single IPv6 Addresses.rcCsxt|t�r|�|�||_dSt|t�rL|�|d�t|�}t|d�|_dSt|�}d|krht d|��|� |�|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. NrrrVrrrrrrr��s      zIPv6Address.__init__cCs t|j�Sr)rUr^r�rrrr�szIPv6Address.packedcCs ||jjkSr�rr�rrrr��s zIPv6Address.is_multicastcst�fdd��jjD��S)r�c3s|]}�|kVqdSrrr r�rrrsz*IPv6Address.is_reserved..)rr�_reserved_networksr�rr�rr�s zIPv6Address.is_reservedcCs ||jjkSr�r"r�rrrr�szIPv6Address.is_link_localcCs ||jjkS�a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )r�_sitelocal_networkr�rrr� is_site_locals zIPv6Address.is_site_localcst�fdd��jjD��S)z�Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv6-special-registry. c3s|]}�|kVqdSrrrr�rrr3sz)IPv6Address.is_private..rr�rr�rr�*s zIPv6Address.is_privatecCs|j S)z�Test if this address is allocated for public networks. Returns: A boolean, true if the address is not reserved per iana-ipv6-special-registry. r�r�rrrr�5s zIPv6Address.is_globalcCs |jdkS)r�rr�r�rrrr�@s zIPv6Address.is_unspecifiedcCs |jdkS)r�r&r�r�rrrr�Ks zIPv6Address.is_loopbackcCs |jd?dkrdSt|jd@�S)z�Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. r?r5N����r^rDr�rrr� ipv4_mappedVs zIPv6Address.ipv4_mappedcCs4|jd?dkrdSt|jd?d@�t|jd@�fS)z�Tuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) �`i NrrGrHr�rrr�teredocs �zIPv6Address.teredocCs$|jd?dkrdSt|jd?d@�S)z�Return the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. �pi N�PrGrHr�rrr� sixtofourrs zIPv6Address.sixtofourN)r;r<r=rBr>r�r�rr�r�r�rFr�r�r�r�rIrKrNrrrrrE�s6%           rEc@s�eZdZdd�Zdd�Zdd�Zdd�Zd d �Zej Z e d d ��Z e d d��Z e dd��Z e dd��Ze dd��Ze dd��ZdS)rPcCs�t|ttf�r2t�||�t|j�|_|j|_ dSt|t �r�t�||d�t |�dkrht |d�|_ n|j|_ t|dd�|_|jj |_ |jj|_dSt|�}t�||d�t|dd�|_|jj |_ |jj |_ |jj|_dSr$)rrFrrEr�rLr^r�rmr}r%rYr�r�r�r[r&rrrr��s(        zIPv6Interface.__init__cCsd|�|j�|jjfSr�r'r�rrrr��s �zIPv6Interface.__str__cCsFt�||�}|r|tkr|Sz|j|jkWStk r@YdSXdSr�)rEr0r1r�r~r(rrrr0�s  zIPv6Interface.__eq__cCsRt�||�}|tkrtSz|j|jkp4|j|jko4|WStk rLYdSXdSr�)rEr4r1r�r~r)rrrr4�s  �zIPv6Interface.__lt__cCs|j|jAt|jj�ASrr*r�rrrr��szIPv6Interface.__hash__cCs t|j�Sr)rEr^r�rrrrc�szIPv6Interface.ipcCsd|�|j�|jfSr�r+r�rrrr��s �zIPv6Interface.with_prefixlencCsd|�|j�|jfSr�r,r�rrrr��s �zIPv6Interface.with_netmaskcCsd|�|j�|jfSr�r-r�rrrr��s �zIPv6Interface.with_hostmaskcCs|jdko|jjSr#)r^r�r�r�rrrr��szIPv6Interface.is_unspecifiedcCs|jdko|jjSr�)r^r�r�r�rrrr��szIPv6Interface.is_loopbackN)r;r<r=r�r�r0r4r�r�r�r�rcr�r�r�r�r�rrrrrP�s$       rPc@s2eZdZdZeZd dd�Zdd�Zedd��Z d S) rLavThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 TcCs|t�||�t|ttf�rs�        )$ $#716=X*vSr 5W{!